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Keyboard

The keyboard functions essentially the same as for any windows application.    The only 
unique features of the keyboard interface involves selecting items and launching 
applications.    The arrow keys may be used to move from item to item.    Hitting return will 
execute the selected item.    Note that you may select multiple items by using the mouse 
only.    

Items may also be selected by hitting the first letter of the item's name.    Repeatedly hitting 
a letter will move you through all item's whose names begin with this letter.    This interface 
will work only in icon display mode.



Folders Commands

To get help with a command, choose the appropriate menu.

File Menu
    New
    Open
    Save
    Name
    Delete
    Run
    Print
    Exit

Edit Menu
    Add item
    Delete item
    Delete file and item
    Delete subfolder
    Move
    Copy
    Properties
    Item icon

Special Menu
    Set default icon
    Arrange icons
    Add association
    Preferences
    Edit run menu 
    Global options

Run Menu
    Popup run menu



File Menu

New - This command create a new folder.    Note that you can create subfolders in subfolders
with essentially no limit on nesting folders within folders.    Be sure and give each folder an 
unique name.    Changing the case of a letter will not make a name unique.    The new folder 
created may either be a subfolder of the current folder or a group-level folder, in which case 
the new folder is placed within a specified group.

Open - This command allows you to open or activate, if already open, any folder on the 
system, regardless of its location .    This allows you to open a specific folder without having 
to hunt it up.

Save - This command saves any changes made to the folder.    Note that some commands 
will automatically perform a save when executed.    They include delete subfolder, rename a 
subfolder, create a subfolder.      The current configuration of a folder may also be saved 
using this command.    The configuration includes the size of the folder, the position of the 
folder and the location of the items in the folder.    Exactly which of these quantities are 
saved can be set using the Preferences command under the Special menu.

Name - Used to change the name of a group-level folder.    The folder icon in the group must 
also be renamed.

Delete - Deletes the group-level folder from which this command is executed.    Note that 
the Program Manager folder icon must also be deleted.

Run - Allows the user to enter a command line to be executed.    The last twelve commands 
entered are stored for easy access.

Print - Prints all selected items provided the file is associated with a program that allows 
printing from outside the program.

Exit - Causes the current folder to be closed.    If has not been saved, and changes have 
been made, you will be prompted on whether or not you want the folder saved.



Edit Menu

Add Item - Adds items to the current folder.    A dialog box is presented from which you may 
choose any file on the system.    After choosing, a descriptive name for the item must be 
entered.    This is the name that will show up under the item's icon.    An icon will then appear
which represents the item just added.    By double-clicking on this icon, the item may be 
executed.    Multiple items may be added by clicking on each file in the file listbox you wish 
to add while holding down the CTRL key.    Clicking again on a selected file will de-select it.

Delete -
Item - This command removes the selected item from the folder.    It does not delete the 
file associated with the item.    It simply removes it from the folder.    If multiple items have 
been selected, a prompt to delete or not appears for each item selected.

File and Item - This command removes the item from the folder and deletes the file 
associated with the item.    As such, use it only when you wish to remove the file 
completely from the disk.    If you wish to only remove the item from the folder, use the 
Delete Item command.    This command does not function with subfolders.    If multiple 
items have been selected, a prompt will appear as to whether or not to delete it for each 
item selected.

Subfolder - Use this command to delete a subfolder.    Note that this command 
completely removes the subfolder.    As such, if you have copied it to another folder and 
wish to be able to still access it from this other folder, use the Delete Item command to 
remove it from the current folder rather than this command.    Also, any subfolders in this 
subfolder are NOT deleted.    So be sure and delete these other subfolders, first.

Move - This command moves the currently selected item to the folder specified.    In doing 
so, it is removed from the current folder.    If multiple items are selected, all items selected 
are moved.    Items may also be moved by dragging them with the mouse to the desired 
folder, which must also be open.

Copy - Works the same as move, but does not remove the item from the current folder.    If 
multiple items are selected, all items selected are copied.    Use this command to link two or 
more folders to the same subfolder.    Simply create the desired subfolder using the File 
menu New command.    Then copy the new folder item to whatever other folders you wish to 
be able to access it.    Items may also be copied by dragging them with the mouse to the 
desired folder.    The right mouse button must be held down when releasing the left mouse 
button for the items to be copied, otherwise they will be moved.

Properties - This command displays and allows you to edit all the properties associated 
with an item.    These properties include the item's descriptive name, its filename, its 
command line, its working directory and its icon.    In addition, a hotkey may be set for the 
item and the item may be set to run minimized or maximized.    Also, for programs the file 
query option may be set to have the program inquire for a file when launched. 

Item Icon - Allows you to specify which icon is to be used to represent an item.    Icons may 
be used located in ICO files, EXE files, DLL files or ICL files (icon libraries).    This command is 
the same as that provided by using the Properties command described above and selecting 
the icon button.    It is provided simply so you do not have to go through the Properties 
command to change the icon.



Special Menu

Set Default Icon - This command allows you to associate an icon with a file extension.    
Doing so, will cause the specified icon to be used to display any item with that particular 
extension unless the item's icon has been set with the Item Icon command.    The new 
associations will not appear until the folder is closed and reopened.    This is true for any 
folder that was open when the changes were made.    Once set, any item with the specified 
extension will appear using the icon associated with that extension.    You should not assign 
default icons to program extensions (exe, com, etc.).

Arrange Icons - Arranges the folder icons in an orderly manner.

Add Association - This command allows you to associate multiple programs with a single 
file extension.    Whenever a data file with multiple associations is executed a list box is 
displayed from which the program to be run may be chosen.

Preferences - This command allow the folder to be customized.    What aspects of a folder 
that are saved when using the Save command may be set from this command.    Also, the 
folder can be set to minimize or close on execution of an item in the folder.    Auto arrange of 
icons can be turned on or off from this command.    Note that if auto arrange is on, the icons 
will be re-arranged everytime the folder is resized or minimized.    The display mode to be 
used, icons, text or button, may be set from this command and a password may be assigned
to the folder by using the Password button.    Finally, the folder may be linked to a directory 
and the sort option to be used may be set from this dialog.

Edit run menu - This command allows you to modify the customizable popup run menu.

Global Options -This command allows various global options to be set.    These include 
turning on and off the confirmation of deletes and saves.    If either is turned off, the 
operation will be performed without requesting confirmation from the user.    Finally, the 
preference settings given to any new folder upon creation may be set from this command.



Run Menu

Displays the popup run menu to allow you to make a selection from it for execution.



Notes on using icons

Folders allows you to use icons present in ICO files, EXE files, DLL files and ICL files.    ICO 
files contain a single icon, while EXE's, DLL's and ICL files may contain one or more icons 
that may be used.    An icon library, folders.icl, is included with the program for your use.    To
use it, simply copy it to the Folders data directory.    Every time you use the Item Icon, or Set 
Default Icon command, the icon dialog box will initially present all the icons in the folders.icl 
for you to choose from.    If the icon you wish to use is not present, simply select the file 
which does have the desired icon and hit Read.    Note that you may basically do anything 
you wish with the folders.icl file without impacting Folders operation.    It may be deleted, 
copied over or edited with a program such as Icon Manager or equivalent.    If it is not 
present, you will simply not have any icons to choose from initially on executing an icon 
command.

Hierarchy of icons:    There is a hierarchy involved in Folders deciding which icon should be 
used to represent an item.    At the top-level, if an item has had an icon explicitly set for it 
using the Item Icon command, this icon will always be used regardless of any other settings 
made.    Next, if the item does not have an icon set for it, but does have an icon associated 
with its extension, this icon will be used.    Finally, if neither of the above is true, if the item is
an executable or is associated with an executable, the icon for that executable will be used.   
If none of the above holds, the item will appear using the default icon..

Limitations: There may be cases where, for some reason, Folders just cannot find the icon in 
the specified file.    In order to use such an icon, you will need to convert it into an ICO file 
using some utility such as Icon Manager.    Once this is done, simple specify the ICO file 
created to use the icon.

Related Topics
      Changing an item's icon
      Setting the default icon



Using the browse button

Various commands provide a browse button to allow you to select a file easily.    To use the 
browse button, simply click on it.    A browse dialog essentially identical to the dialog used by
the Add item command is provided.    Find the file in the file listbox you wish to make use of 
and click on it.    The current directory may be changed using the directory listbox on the 
right.    Once you have selected a file, click on OK and it will appear in the dialog box of the 
command being executed.



Using the Preferences command

1.    Select Preferences from the Special menu.

2.    From the dialog box presented, several options may be set to customize the folder as 
explained below.

Save Configuration options: When executing a Save command, the choices selected 
here will govern what information about the folder is saved.    Information that can be 
saved include the folder size and position.    Any option not selected will not be saved.   
Note that item positions are always saved.

Minimize on use, Close on use options: Selecting one of these will cause the folder to 
be either minimized or closed when an item in the folder is executed.

Open minimized:    Selecting this option will cause the folder to always be opened as an
icon on the desktop.

Auto Arrange switch: When this option is activated, the folder item icons will 
automatically be rearranged whenever the folder is resized or minimized.    If you wish 
to keep the folder items in specific locations at all times, do not use this option.

Display mode: Each folder may be displayed in one of three different modes.    The 
normal mode is icon display.    In this mode, each item appears as its own icon with a 
caption.    The second mode available is button mode.    In this mode, the folder 
appears as a series of buttons which may be pushed to execute an item.    Note that in 
this mode, many of the folder commands are not available.    Also, while items may be 
added to the folder using drag/drop, they may not be deleted while in button mode.    
Finally, the folder may be set to text mode which displays the items using only their 
names.    

Show extensions: When in listbox display mode, the item file extensions will be 
displayed as part of the name if this option is set.

3.    A password may be assigned to the folder through the use of the 'Password...' button.    
Clicking on it will produce a dialog box in which you may enter the desired password for this 
folder.    The next time the folder is opened, this password will need to be entered before you
will be able to access the folder.    To clear the password, simple select this function again 
and enter a blank line for the password.

4. The background color of the folder may be set using the Color button (see Changing the 
color of the folder).    

5. The sort used to arrange items in the folder may be set using the 'Sort by...' button (see 
Setting the sort type).    Sorting may also be disabled from this dialog.

6.    Click on OK to return to the folder window.    Note that a Save must be performed for the 
preferences to be saved.



Adding items to a folder

1. Select Add Item from the Edit menu.

2. From the dialog box that appears, choose the file you wish to add.    Multiple files may be 
selected by simply clicking on each file to be added while holding down the CTRL key.    To 
de-select a file, click on it again.    Use the directory list box on the right to change 
directories.    All highlighted files will be added.    Click on OK.    Note that files may be added 
from a single directory only.

3. Enter the descriptive name for each item that you wish to have appear under the item 
icon.    Hitting the Cancel button at this point will cause the current item not to be added.    
Any other items selected will still be added.    Note that by double-clicking on the 'File:' field 
of the dialog, you may display the file name of the item with its extension.

4. After names have been entered for all selected files, the new items should appear in the 
folder.



Changing an item's icon

1.    Select the item whose icon you want to change    by clicking on it with the mouse.

2.    Select Item Icon from the Edit menu.    The icon browser dialog will appear.

3. From the dialog box, choose the new icon to be used to represent the selected item.    To 
use an icon in a specific file, select the file using the Open button.    A common dialog for 
selecting a file will appear from which the desired file may be selected.    All icons in that file 
will then be displayed in the icon listbox.    In the icon listbox, select the desired icon and 
click on Select.

4.    The item should appear with the new icon.

Related Topics
      Notes on using icons
      Properties command
    Setting the default icon



Changing the properties of an item

1. Select the item whose properties are to be viewed or edited by clicking on it with the 
mouse.    Select the Properties command from the Edit menu.

2. The item name, file name, command line and working directory may be edited by 
changing the value in the appropriate edit field.    Note that by entering a blank line for the 
command line or working directory, the default functionality of the item will be restored.    
Also, by entering 'Current directory' (no quotes) the directory will not be changed when 
executing that item.

3. The item icon may be set by clicking on the icon button provided.    Doing so will bring up 
the icon browser dialog from which the new icon may be selected.

4. The item may be set to run minimized or maximized by clicking on the appropriate check 
box.    

5.    Finally, a hotkey may be assigned to the item and a file query option may be set from 
the dialog brought up by clicking on the 'More properties...' button.    To set a hotkey, enter 
the letter for the hotkey.    Using the checkboxes provided set up the desired combination of 
keys to be used to active the hotkey.    Programs may be set to prompt for a file by checking 
the 'File query' checkbox.

6.    Click on OK when all desired changes are complete.

Related topics
Changing an item's icon



Copying items from folder to folder

1.    Select the item you wish to copy by clicking on it with the mouse.    Multiple items may 
be selected by holding down the CTRL key while clicking on each item.

2.    Select Copy from the Edit menu.

3.    From the dialog box, select the folder you want the item(s) copied to.    Click on OK.

4.    The item(s) will now be copied to the specified folder.

or

1. Make sure the folder you wish to copy the selected items to is open or is a subfolder of the
current folder.

2. Select the items to be copied in the same manner as above, but on the last item selected 
continue to hold down the left mouse button.

3. Drag the cursor to the folder you wish to copy the items to.    The cursor will be a 
monochrome version of the selected item if only a single item is selected.    If multiple items 
are selected, it will be a generic drag item cursor.

4. While holding down the right mouse button, release the left mouse button while the 
cursor is over the folder you want to copy the items to.    If the cursor is a circle with a line 
across it, you are over an illegal drop point.

5. Once the left mouse button has been release, the right mouse button may also be 
released.    The selected items will be copied to the specified folder.

Using this command, one can link the same subfolder to two or more other folders.    Simply 
copy the subfolder to the folder you wish to also have access to it.

Related Topics
    Moving items from folder to folder



Creating a new folder

1.    Select New from the File menu.

2.    Enter the name of the new folder.    This name MUST be unique.    Upper or lower case do 
not make any difference.

3. Select the type of folder, either 'Subfolder' or 'Group-level folder'.    Subfolders are placed 
in the current folder.    Group-level folders are placed within a Program Manager group.    Click
on OK.

4.    If subfolder was chosen a new folder icon representing the new folder should appear in 
the current folder.    Otherwise, a dialog will appear from which you must select the group the
new folder is to be placed in.    Once selected, a new folder icon will appear in the group 
chosen.

The preferences of the new folder will be set to the same settings as those specified in the 
new folder settings dialog brought up from the global options dialog.

Related Topics
      Deleting a folder



Deleting an item

1.    Select the item you wish to delete by clicking on it with the mouse.    Multiple items may 
be selected for deletion by holding down the CTRL key while clicking on each item to be 
deleted.

2.    Select Delete Item from the Edit menu.

3.    You will be asked if you wish to delete the selected item.    Click on Yes or No.

4.    If you clicked on Yes, the item will be deleted from the folder.    Note that if you 
accidentally delete an item, close the folder without saving it.    When you reopen it, the item
will still be there.

Related Topics
    Deleting an item and its file
      Deleting a subfolder



Deleting an item and its file

1.    Select the item you wish to delete by clicking on it with the mouse.    Multiple items may 
be selected for deletion by holding down the CTRL key while clicking on each item to be 
deleted.

2.    Select Delete File and Item from the Edit menu.

3.    You will be asked if you want to delete the selected item and its file.    Click on Yes or No.

4.    If you clicked on Yes, the item will be removed from the folder and the item's associated 
file will be erased from the disk.

Related Topics
      Deleting an item
      Deleting a subfolder



Deleting a folder

To delete a subfolder, perform the following:

1.    Select the subfolder you wish to delete by clicking on it with the mouse.

2.    Select Delete Subfolder from the Edit menu.

3.    You will be asked if you want to delete this subfolder.    Click on Yes or No.

4.    If you clicked on Yes, the subfolder will be removed from the system.    Note that if the 
subfolder has been copied to other folders, it must be removed from those folders using the 
Delete Item command.

To delete a group level folder, perform the following:

1. Open the group-level folder to be deleted.

2. Select the Delete command from the File menu.

3. You will be asked if you want to delete this subfolder.    Click on Yes or No.

4. If you clicked on Yes, the folder will be removed from the system.    Note that if the folder 
has been copied to other folders, it must be removed from those folders using the Delete 
Item command.

5. Finally, the folder icon should be deleted from the group in which it was located.

Note that any subfolders contained in the deleted folder will NOT be deleted.    They should 
be removed through use of this command before deleting the subfolder they are contained 
within.

Related Topics
        Deleting an item
        Deleting an item and its file



Editing the run menu

A customizable popup run menu is provided from which programs may be run.      A menu 
editor dialog is supplied to build and maintain this popup menu.    It may be accessed by 
selecting    the 'Edit run menu...' command under the menu command Special in the main 
Folders window.    This editor may be used to add items, including separators and submenus, 
to update item's properties or to delete items from the run menu. 

Adding run menu items:
1.    Select the item from the menu listbox you wish the new item to appear under.    By 
selecting the ---- Top of Menu ---- place holder a new item may be added at the top of the 
menu.

2.    Select the 'Add' button.    A dialog will appear in which you can set the properties of the 
new item.

3.    Click on the desired type of item, normal, submenu or separator.

3.    Fill in the name for the new item and its corresponding command line.    If desired, fill in a
help line (this will appear in the status bar when the menu item is selected.    The 'Browse' 
button will bring up a dialog which may be used to select a file for the command line.    Note 
that the command line field should not be modified for separator and submenu item types.

4.    The menu item may be set to run minimized or maximized by checking the appropriate 
checkbox.    In addition, by checking the file query checkbox you will be prompted to enter a 
file whenever the item is run.

5.    Finally, a hotkey may be set for the item.    Enter a letter for the hotkey and check the 
key combination you wish to use to activate it.

6.    Click on OK and the new item will be added to the run menu.

Certain special commands are provided for use in the run menu.    These commands may be 
accessed by clicking on the 'Special...' button.    The commands available include arrange 
icons, cascade windows, tile windows, exit windows and task list.    The default names for all 
of these commands except for task list may be changed, if desired.    Do not change the 
command lines.

Updating an item:
1.    Select the item from the menu list box whose properties you wish to change.

2.    Click on the Update button.

3.    Make any desired changes to the menu item's properties.    Click on OK to set the 
changes.

Deleting an item:
1.    Select the item from the menu listbox you wish to remove from the run menu. 

2.    Click on the Delete button and the item will be removed from the menu.

Cutting and Pasting:
Using the 'Cut' and 'Paste' buttons items may be moved around the menu.    Select the menu
item from the menu listbox you with to move.    Click on the 'Cut' button.    Select the item 
you wish the cut item to appear under.    Click on the 'Paste' button to place the item.    Note 



that items may be moved to submenus using this procedure.

Creating submenus:
1.    Add a new item for which you have selected the Submenu radio button for the item type.
Be sure not to modify the command line when adding the item.    Only the name for the 
submenu needs to be specified.

2.    Select the newly added submenu item.    The >>> button will now be enabled.    Clicking 
on this button will allow you to build the menu to be associated with the submenu item 
added in step 1.

3.    To return to the parent menu, click on the <<< button.    You may have as many 
submenus as you desire and the submenus may have submenus of their own.    They may be
edited in the exact same manner as the main parent menu.

Once you have made all the desired changes to the run menu, click on the OK button to exit 
the dialog and save the new menu.    The newly edited popup run menu will now be 
accessible from the main menu Run command.



Executing an item

1.    Double-click on an item's icon to execute it.
                  or
2.    Click on it with the mouse and hit the enter key.
                  or
3.    Use the arrow keys to select the item.    Hit    the enter key.



Exiting a folder

1.    Select Exit from the File menu or Close from the System menu.

2.    If changes have been made to the folder since the last save, you will be prompted for 
whether or not you wish to save the folder.    Clicking on Yes will save and exit the folder.    
Clicking on No will exit the folder without saving.    Clicking on Cancel will cancel the exit 
operation and return you to the folder.



Global options settings

Various global options may be set using the Global Options command found under the 
Special menu of the main Folders window.    These options include:

Confirmation settings:
Confirm on delete - checking this box will cause a confirmation box to be presented for 
the user to confirm the delete.    If not checked, the delete will occur automatically.

Confirm save on exit - normally upon exiting a folder you are presented with the option of 
saving any changes that have been made to the folder.    If this option is unchecked, the 
save will be performed automatically upon exit.

Confirm Windows exit - this option controls whether or not to confirm exiting Windows.

Status bar on:
This option controls whether or not the status bar is displayed in a folder.

Arrange top down:
By clicking on the 'Top down' checkbox, the items in folders will be arranged from the top-
down rather than the bottom-up.    Note that it is highly recommend that the auto arrange
option in the preference dialog be left on if using top-down arrangement.

Folder icon:
By clicking on the folder icon button, the icon to be used to represent folders may be set.  
Upon clicking on the folder icon button, the icon browser dialog will be presented to allow 
you to select the desired icon.    See the section on changing an item's icon for a 
description on how to use the icon browser dialog.    Once an icon has been selected, all 
folder icons will be changed to the selected icon.

New folder settings:
These settings are accessed by clicking on the 'New folder settings...' button.    All of the 
options provided in the New Folder Settings dialog are used to set the preferences any 
new folder will be created with.    These settings are used only when a new folder is 
created and once the folder has been created, its preferences settings may be changed 
using the Preferences command.

Rebuild button:
By clicking on the rebuild button, the folder list maintained in the folders.ini file will be 
updated to accurately reflect all folders currently present in the folders data directory.    
You should use this function if the Open command is not listing all folders accurately.

Recover button:
This function is useful to recover folders whose icons have been lost for some reason.    
When clicked on a dialog will appear listing all folders currently in the folders data 
directory.    Select the folder you wish to recover and click on OK.    A new folder icon will 
appear in the current folder from which the recovered folder may be accessed.    If this 
folder was a group-level folder, it may be added to a Program Manager group by dragging 
and dropping it on the group you wish to add it to.

Related topics
    Changing an item's icon
    Using the Preferences command



Moving items from folder to folder

1.    Select the item you wish to move by clicking on it with the mouse.    Multiple items may 
be selected by holding down the CTRL key while clicking on each item.

2.    Select Move from the Edit menu.

3.    From the dialog box, select the folder you want the item(s) moved to.    Click on OK.

4.    The item(s) will now be moved to the specified folder.

or

1. Make sure the folder you wish to move the selected items to is open or is a subfolder of 
the current folder.

2. Select the items to be moved in the same manner as above, but on the last item selected 
continue to hold down the left mouse button.

3. Drag the cursor to the folder you wish to move the items to.    The cursor will be a 
monochrome version of the selected item if only a single item is selected.    If multiple items 
are selected, it will be a generic drag item cursor.

4. Release the left mouse button while the cursor is over the folder you want to move the 
items to.    If the cursor is a circle with a line across it, you are over an illegal drop point.    
The selected items will be moved to the specified folder.

Related Topics
    Copying items from folder to folder



Opening a folder

1.    Select Open from the File menu.

2.    Choose the folder you wish to have opened from the list in the dialog box.    Click on OK
.
3.    If the folder selected has not been previously open, it will be opened and appear in a 
second window.    If it is already open, it will be made the active window.    If is already open 
and minimized, its icon will be opened into the active window.



Saving a folder

1.    Select Save from the File menu.

2.    All change made to the folder will be saved.      In order to save a folder's size or position, 
or the position of the items in the folder, a Save must be executed and the appropriate 
option must be selected in the Preferences dialog.    The exact information saved is 
determined by the options selected using the Preferences command.

Related Topics
      Using the Preferences command



Setting a default icon

1.    Select the item whose file extension you wish to assign a default icon to.

2.    Select Set Default Icon from the Special menu.

3. From the dialog box, choose the new icon to be used to represent the selected item.    To 
use an icon in a specific file, select the file using the Open button.    A common dialog for 
selecting a file will appear from which the desired file may be selected.    All icons in that file 
will then be displayed in the icon listbox.    In the icon listbox, select the desired icon and 
click on Select.

4.    To see the new icons, close and reopen the folder.

Note that these associations will apply to all folders, not just the one they are set in.    To 
remove any association previously set the folders.ini file must be edited.    Open it with a text
editor like Notepad.    Under the section [Icon Extensions] delete the line containing the 
extension you wish to de-associate.    Save the file.    The items should now appear using 
their old icons.    To clear all default icons assigned, simply delete the file FOLDERS.DFI in 
your folders data directory.

Related Topics
      Changing an item's icon



Setting the folder icon

1. Select the Global Options command from the Special menu.

2. Click on the Folder Icon button.

3. From the icon browse box select the icon to be used as the folder item icon.    Click on OK.

4. All subfolders and minimized folders will now appear using the selected icon.

Related Topic
      Changing an item's icon



Setting the password

1. Select the Preferences command from the Special menu.

2. Click on the Password button.

3. Enter the desired password in the input box.    Click on OK.

4. Once the password is set and saved, every time the folder is opened the password will 
need to be entered before the folder will open.

To clear a password, perform steps 1 and 2 above, but instead of entering a password, 
simply leave the line blank and click on OK.    The password will then be cleared.

Note that this password scheme is not unbreakable.    It will keep out most users, but a 
determined computer professional will be able to break it.

Related Topic
    Using the preferences command



Having folders open on startup

There are two ways in which you may have specified folders open automatically on Windows
startup. 

The first method involves making use of the startup group.    By placing the folder icons of 
the folders to be opened in the startup group selected folders may be opened and available 
on Windows startup.    To add a folder to the startup group either create a new group-level 
folder in the startup group, or move/copy a current group-level folder to the startup group.    
You can also drag subfolder icons to the startup group to have them open on start up.    To 
have an item start as an icon on the desktop, simply select the 'Run minimized' option of the
Properties dialog for that particular item or set the Open minimized option in the folder's 
Preferences dialog.

The second, and more awkward method, involves editing the WIN.INI file.    First, open the 
FOLDERS.INI file with an editor such as Notepad.    Under the section [Folder list] find the 
folder(s) you wish to have opened on Windows startup.    Make a note of the DOS file name 
to the right of the equal sign.    Close this file and open WIN.INI.    On    the load= or run= lines
add the DOS file name you noted from the FOLDERS.INI file.    Save and close the WIN.INI file.
The next time you start Windows, the specified folders should open.



Associating programs with file extensions

Application programs may be associated with a particular file extension.    For example, 
Notepad may be associated with TXT files.    Executing a file with a program associated with 
its extension will cause the associated program to be run using the file as the data file.    For 
instance, if TXT is associated with Notepad, running the file readme.txt would cause Notepad
to run and load the file readme.txt.    Windows normally only allows a single program to be 
associated with an extension.    However, Folders provides a command which allows multiply 
programs to be associated with an extension.    Whenever a data file with multiple 
associations is executed from Folders, a list box will appear from which the desired program 
to be run may be chosen.

To associate additional programs, follow these steps:

1. Select the folder item whose filename's extension you wish to associate a program with.

2. From the Special menu, select the command Add Association.

3. A dialog box will appear in which you may enter the name of the program you wish to 
associate or the program may be selected using the Browse button.    Click on OK to set the 
association.

4. If you wish to view any other associations that have been previously set, click on the 
down arrow at the right of the input box.    A list of all other associations that have been set 
will appear.    To close the list, simply click on the down arrow again.

To remove a previously set association, follow steps 1 through 3, but on step 3 click on the 
down arrow at the right of the input box.    From the list of associations that appear, click on 
the association you wish to remove.    The program selection should appear in the input box.  
Click on OK and the association selected will be removed.



Using the Run command

1. Select Run from the File menu.

2. In the dialog box that appears, type in the command you wish to execute.    Or, use the 
browse button to select a file to be executed.

3. Click on OK.    The command entered will be executed.    By clicking on the 'Run minimized'
checkbox, the program will appear as an icon on the desktop.    By clicking on the 'Run 
maximized' checkbox, the program will be run in a maximized window.

Notes: The Run command stores the last twelve commands executed, throwing out 
duplicates.    When the Run command is selected, the last command entered using the Run 
command will automatically appear in the input box.    To execute it, simply click on OK.    To 
access the other eleven commands stored, click on the down arrow at the right of the input 
box.    A list will appear containing the other eleven commands.    Click on the command you 
wish to execute, and then click on OK.    The command will be run.



Changing the color of a folder

The background color of the folder may be changed through the use of the 'Color...' button in
the preferences dialog.    To change the color, simply bring up the preferences dialog and 
select the 'Color...' button.    From the dialog which appears, select the desired color for the 
folder.    Note that the background color is only used when the folder is displayed in icon 
mode.    Also, once the folder color is set, it cannot be changed through the use of the 
Windows Control Panel utility.

Related topics
    Using the Preferences command



Setting the sort type to be used

The way the items in a folder are sorted for display may be selected through the use of the 
'Sort by...' button in the preferences dialog.    Four different types of sorts are available, the 
default sort (all folders use this sort method initially), sort by item name, sort by file name, 
and sort by file extension.    In addition, an option is available to always force the folders to 
appear in the corner of the folder.    

To set the sort type, simply bring up the preferences dialog and select the 'Sort by...' button.  
From the dialog which appears select the desired sort type and whether or not the folders 
should always appear starting in the corner.    Click on OK.    Note that the new sort will not 
take effect until the folder is closed and reopened.

If you want to lock in the positions of the items in the folder, sorting needs to be turned off.   
To do so, simply click on the 'Disable sorting of items' checkbox.

Related topics
    Using the Preferences command



Drag/drop procedures

A number of different drag/drop procedures are provided with the program.    They are as 
follows.

1.    You may move or copy items from folder to folder by dragging them from the source 
folder to the destination folder.    Multiple items may be dragged by holding down the control 
button and clicking on each item to be dragged.    On the last item, the mouse button should 
be held down and the drag commenced.    To copy items, hold down the right mouse button 
when you drop them on the destination folder.

2.    You may move or copy items to a subfolder of the current folder by dragging the 
selected items to the subfolder icon in the current folder and dropping them.    Note that you 
cannot move items to a subfolder of a different folder using this method.

3.    Data files may be loaded into programs by dragging the folder item to the program item. 
The program item may either be another folder item or may be a program already running 
and present on the desktop.    Note that if dragging to a program on the desktop that not all 
programs will accept dropped files.    If the no drop symbol is present then the program does 
not accept dropped files.

4.    You may move items within a folder by dragging them and dropping them in the new 
location.    Care must be taken as if they are dropped on a subfolder icon they will be moved 
into the subfolder.    Also, if moved onto a program, the program will be launched.

5.    Items may be added to a folder by dragging files from the File Manager.    To do so, open 
the folder you wish the new items to be added to.    Select the files to be added from the File 
Manager.    Drag the files selected to the folder and release the mouse button.    You will then 
be given the opportunity to give descriptive names to each file which will then be added to 
the folder.

6.    Items may be printed by dragging the item to the Print Manager.    Print Manager may 
either be a folder item itself in the current folder or be running on the desktop.



Printing a folder item

Folder items may be printed by simply selecting the 'Print' command under the File menu.    
If the item(s) selected is associated with a program that allows printing from outside the 
program, the file will be printed.    To print multiple items, simply select the items desired 
while holding down the CTRL key and then execute the print command.

If the item does not print, then the program associated with the data file does not allow 
printing outside of itself.



Launching multiple programs at once

It is possible to launch multiple programs with a single action.    To do so, simply select all the
items to be launched.    Selection is performed by clicking on each desired item while holding
down the CTRL key.    After this, just hit the enter key.    All items selected will be run.

To run everything in a folder without having to select every item, simply hit the enter key 
while holding down the CTRL key.    Every item in the folder will be run.

All items in a folder may also be launched by double-clicking on the folder icon in the parent 
folder while holding down the ALT key.

Items are launched in order from left to right.    To have the items launched in a particular 
order, arrange them in the folder from left to right.    Then go to the preferences dialog and 
click on the 'Sort by...' button.    Disable sorting from the dialog which appears.    Save and 
exit the folder.    The items in the folder will now be launched in the order specified from left 
to right.



Miscellaneous mouse functions

Various special mouse operation unique to Folders are available.    They are as follows.

1.    Clicking the right mouse button on a folder item while in icon display mode brings up the
properties dialog of that item.

2.    Clicking the left button while holding down the CTRL key when the folder is in button 
display mode brings up that item's properties dialog.

3.    To select a folder item, click on the item with the left mouse button.

4.    To select multiple items, click on each item with the left mouse button while holding 
down the CTRL key.

5. Clicking the left mouse button on the status bar will bring up the preferences dialog.



Special Dialog

Several special commands are provided for use with the popup run menu.    They include:

Task list - displays a list of all the currently running applications.

Arrange icons - arranges the icons on the desktop into orderly rows.

Cascade windows - cascades all open windows on the desktop.

Tile windows - tiles all open windows on the desktop.

Exit windows - exits Windows.    Whether or not a confirmation dialog appears is controlled 
by the appropriate setting in the global options dialog.

Related topics
    Editing the popup run menu




